Notes

Connect App - Project

Connect App - Project's Notes

Twitter and Facebook Connect seem to be working now. I'm still not happy with the authorization and authentication workflows. Twitter Connect is now only available for people actors for simplicity sake. Facebook works in readonly mode which means we can't post from Anahita to Facebook anymore. That's because facebook has deprecated publish_stream and publish_actions permissions.

Yes the #ConnectApp needs some love. User #OnBoarding needs to be more straightforward. LinkedOn pairing has stopped working. We need to upgrade to OAuth 2

After fixing a series of bugs in Anahita I spent some time looking into the Connect App issues. Currently we cannot pair with Twitter, Facebook, and LinkedIn possibly due to API changes by those service providers. I am going to look into it later this week or Saturday. In the mean time if anybody else managed to find the issue and provide a patch we really appreciate it. Keep me posted.

I've branched out Anahita ™ Connect for updating to Anahita 1.6 codebase. You can follow the development branch at http://svn.anahitapolis.com/connect/branches/. Cheers

Looks like a facebook API change has broken the connect app, well only for the facebook service.

I had some progress debugging the Anahita Connect issues, though the work is incomplete. One of the challenges is that services like facebook can only be tested from the server and not the local development machine. Also the twitter connect seems to be working fine on my machine, but not on the server which is strange. I need to do more testing on the staging installation that I have created. In the mean time if you have found any issues or fixed any bugs in the connect app please let me know... Read More
I had some progress debugging the Anahita Connect issues, though the work is incomplete. One of the challenges is that services like facebook can only be tested from the server and not the local development machine. Also the twitter connect seems to be working fine on my machine, but not on the server which is strange. I need to do more testing on the staging installation that I have created. In the mean time if you have found any issues or fixed any bugs in the connect app please let me know or do a pull request on the GitHub. Read Less
2 people liked this

Looks like Anahita Connect 1.6-branch is ready for the embryo release

Powered by Anahita