Topics

Anahita Project

Anahita Project's Topics

Patrick Thach

Patrick Thach

June 30 2013

Unable to install Anahita Standard

I followed the installation steps for developers.

Here : https://github.com/anahitasocial/anahita-standard

Linking files... Enter the name of the database? (default: anahita) Enter the database user? (default: anahita) Enter the database password? (default: google) Enter the database host address? (default: 127.0.0.1) Enter the database port? (default: 3306) Enter a prefix for the tables in the database? (default: jos_) bt_ connecting to database... Congradulation you're done.

Accessed my webproject http://anahita.local/ and I got this..

jtablesession::Store Failed DB function failed with error number 1146 Table 'anahita.bt_session' doesn't exist SQL=INSERT INTO `bt_session` ( `session_id`,`time`,`username`,`gid`,`guest`,`client_id` ) VALUES ( '8451373d756d6d190c3e36c106f36c11','1372619816','','0','1','0' )

Seems like the console script did not import any of the anahita schemas.

mysql> use anahita; Database changed mysql> show tables; Empty set (0.00 sec)

Can you take a look?

Thanks,

Patrick T.

Hi Patrick,

This is the line that imports the data. https://github.com/anahitasocial/anahita/blob/master/Console/tasks/site.task.php#L173. It's in your vendor/anahtia/anahita. Can you check if that line being run in your installation. Also just try the default prefix just in case.
@Patrick

If you on windows, current console installer doesn't work on it, i created special topic for that http://www.anahitapolis.com/topics/117140
Unknown Person liked this
@Arash
After my own installation experience i can confirm the problem. The reason behind it is that if database exists (e.g. empty database) when site:init is ran, no tables are created.
Installer must work with existing but empty database since very often in controlled hosting environments one can't have database user credentials without creating database which would be linked to it.

Also, custom database prefix doesn't work, as some point after providing admin password and email init script gives this exception

[KDatabaseException]  Table 'evolve.jos_anahita_nodes' doesn't exist of the following query : SHOW COLUMNS FROM jos_anahita_nodes
Hi Taylor,

That's right. That's for security reason. By default if the database exist, it won't drop it. If you do anahita site:init --help you can see there's a flag called --drop-database. use this flag if the database exist so it will drop it.
well, i have experience with many installation packages, such logic is not intuitive (i guess this is the reason for Patrick to have his problem in the 1st place), empty existing database should be equivalent to no database, i.e. installation should proceed without any issues. Again, it's often a case when empty database already exists. It would be cool just to run 'show tables' and if result is empty, proceed with creating tables, instead of checking for database existance.
Arash Sanieyan liked this
That sounds good. I can perhaps add that in.
@Arash,
i'm not you've noticed, since you didn't respond to that, but there is a pure bug in console installer: it's not possible to use custom database prefix, please see database exception i referenced earlier
Arash Sanieyan liked this
Oh yes I missed that .will fix the prefix bug.

Powered by Anahita