Tribe Support

Tribe Support's Topics

Unknown Person

May 26 2015

Composer update

Just ran a composer update for my live site.Watching composer do its job, all appeared to be in order.

Loading composer repositories with package information

Updating dependencies (including require-dev)

- Installing anahita/anahita (4.1.0)

Downloading: 100%

Writing lock file

Generating autoload files

And that's where it stopped, and returned to

So.., my project was not updated at all.

Do I need to put require 'vendor/autoload.php', in json, or should I be using composer.phar install instead of update?

I double checked composer.json and composer.lock and they look ok to me.

What am I missing?

I await your reply with giggly anticipation :-)

Unknown Person
May 28 2015 Permalink
Yes that did fix it,..eventually. I don't know why, but i'm having to repeatedly reasert ownership and permissions for it to work. Most annoying.
Now I've just gotta sort out why i'm getting the 'failed to load resource' internal 500 error
Sometimes, I think that I took it far too literally when I read Pascals' "Begin before you are ready" :-)
Do you get 500 error when you go to mysite/people/session ?
Is the SEF URL on or off on your global config?
Do you have a .htaccess file in your www directory?
Unknown Person
May 28 2015 Permalink
I'm going blind :-) Can't find the SEF URL.

The error only occurs when clicking the login button and the modal won't load.
Anahita doesn't report the error. I only found it when viewing the page source and saw the error there.
I do have .htaccess in www
Just had a look at it and I'm wandering if I should uncomment the
# RewriteBase /
Unknown Person
May 28 2015 Permalink
Just did
#Options +FollowSymLinks in .htaccess
and did php anahita site:symlink again, but to no avail.
Sorry, it is global configuration > Use mod_rewrite
Unknown Person
May 28 2015 Permalink
Ah, yes it is 'on'
Unknown Person
May 28 2015 Permalink
Should either of these be changed in anyway in .htaccess?
Options +FollowSymLinks

# mod_rewrite in use

RewriteEngine On
Unknown Person
May 28 2015 Permalink
Just had another at apache error.log and found this (spambot) for lack of a better description, trying to invade every single new file that I just installed from the anahita repo. This day is not going my way. Shutting down.

Warning: Invalid argument supplied for foreach() in /var/www/myproject/vendor/anahita/anahita/vendor/nooku/libraries/koowa/http/url.php on line 326, referer: "popularsearchengine"/search?q=nasty+1+verynasty
you don't have to change anything in the .htaccess

do you have the option of using Nginx instead of Apache. It is faster and easier to configure/maintain too.
Unknown Person
May 28 2015 Permalink
Yes I do have that option. Nginx is present in the Ubuntu repositories by default.
I could just
sudo apt-get update
sudo apt-get install nginx
configure and migrate from apache.
It'll give me something new to do and help shake off the plague of bugs that 'I've' no doubt created :-)
Thanks for the suggestion. I dub thee Sir. @Rastin of Anahitapolis :-)
Let me know how it goes with Nginx. You'll probably like it more than Apache.
Unknown Person
May 30 2015 Permalink
Will do, thanks @Rastin :-) I'm taking a brain break from all tech for the next three days though. On the fourth day, I'll install Nginx and migrate.

Did the latest update on the off chance that it might solve a couple of my current issues but it's evident that they're all server side.
Rastin Mehr liked this
Unknown Person
June 05 2015 Permalink
My apologies for not reporting back to you on that 'Fourth' day. I generally "Do what I say and say what I mean" :-)
However, after following several tutorials in order to get to know Nginx and those with experience using it, I discovered a few flaws in the way that those tutorials have been documented. So, I'm working on a less flawed version of those tutorials in order to introduce a little more clarity for those who learn in the evening, and find themselves still working til morning—on that 'fourth day' :-)
Unknown Person
June 05 2015 Permalink
Yes, thank you, that is a helpful tutorial. However, not even that one states 'early on', that index.php must be placed in the index settings along with index.html etc. Without doing that, and even after configuring Nginx to run php, you'll get 403 and even 404 error pages returned. I'll create a tutorial that starts at installing Ubuntu --> Install and migrate from Apache to Nginx (Fully Configured)--> MySql (Fully Configured) --> phpMyAdmin (Secured) --> php5 --> Anahita (installed and first admin user created)
I have not found a flawless Nginx install tutorial let alone one that that documents how to migrate from Apache to Nginx. They come very close, but every singe one leaves you looking for the answer to some misconfiguration. It would be nice if some one out there would just document it correctly, start to finish for a change. I'm tired of following tutorials that inevitably leaves the would-be student with something that just doesn't work. Although there is value in trouble shooting in order to learn something new, one grows weary with repeated failure do to subtle gaps in knowledge. I want to create a tutorial that, when adhered to,..just works :-)
Bent Rune Skulevold liked this
Interesting topic to follow - Thanks for bringing it up Scott, and I am sure the tutorial will be great to :) asdf
Unknown Person liked this
I think it would be much easier if you'd built a brand new server and Anahita installation and then bring over your database dump. For the assets, just upload them to an Amazon bucket and then point your installation to it. It is really affordable. Our last month's storage bill was less than $2
Unknown Person liked this

Powered by Anahita