Topics

Tribe Support

Tribe Support's Topics

Hunter Wilkes

3 weeks ago

get_viewer()

I'm seeing get_viewer() being called, but I can't seem to find where it's defined. Could someone either tell me what it does or where it's defined?Thanks,

Hunter

Awesome, thanks!
What code editor are you using?
It is basically KService::get('com:people.viewer') use this if possible.
Since I'm on a windows machine and the server with the website is on a linux machine, and I'm not too familiar with all this stuff, I'm just using putty to connect to the server and then using vim.
You can use a virtual machine and vagrant to create a Linux environment on you windows machine
I use WAMP on Windows to develop local. It's really a huge performance boost than working remotely.

No matter what, you should install an Integrated Development Environment (IDE). I've used Atom in the past which is free and pretty good. I use Sublime Text which I love, but does cost $75.

You should download or git clone the anahita repo localy, create a project in the IDE, and from there you'll be able to do full text search of all the files. It makes it a lot easier to figure out where functions are defined and how everything works.
I use PhpStorm and Atom. I find myself using Atom more and more for both mobile and Anahita development.
Scott Crawford
Scott Crawford
2 weeks ago Permalink
nicholasjohn16 - Did you have any issues at first getting Anahita to fully install on Wampserver? I'm having nearly the same issues with Wamp as I did with XAMPP... Composer correctly downloads Anahita, but when running site:init the database is properly setup however the filesystem is not fully setup. On both Wampserver and XAMPP the command line replies with two errors that the 'cp' command is not recognized.
@Scott, cp is a Linux command and there's no such command on Windows so the installer fails using the Command Prompt. You have to either install Cygwin or use a Linux dev enviroment. I use Cygwin.

Anahita CLI is a bit buggy on Windows. I've tried patching things here and there as I find them, but there's a good amount of work to make it really cross platform.
Rastin Mehr liked this
Scott Crawford
Scott Crawford
2 weeks ago Permalink
Yeah I've been running Cygwin as well but it's still not creating the symlinks. I typically use a remote dev server but ideally I'd prefer a local capability. Next step might be a Linux partition or see if the Pi Zero is up to the task.
We've gone way off topic here :) I think a vagrant box solution would be better similar to this https://github.com/joomlatools/joomlatools-vagrant that is something I'd like to accomplish if time allows.
@Scott, be sure to launch Cygwin as an Administrator.
Unkown Person liked this

Powered by Anahita