Topics

Tribe Support

Tribe Support's Topics

Rajkumar Mundel

Rajkumar Mundel

May 03 2020

Fatal Error When I click on Signup

Hello,When i create my 2nd user after creating Admin user, below error is showing... Any idea ?

  • Fatal error: Uncaught InvalidArgumentException: Response message is missing in /home/anahita/src/libraries/default/base/controller/response/response.php:148 Stack trace: #0 /home/anahita/src/libraries/default/base/controller/response/response.php(164): LibBaseControllerResponse->setStatus(530) #1 /home/anahita/src/components/com_application/dispatcher.php(394): LibBaseControllerResponse->__set('status', 530) #2 /home/anahita/src/libraries/anahita/controller/abstract.php(142): ComApplicationDispatcher->_actionException(Object(AnCommandContext)) #3 /home/anahita/src/components/com_base/dispatchers/default.php(170): AnControllerAbstract->execute('exception', Object(AnCommandContext)) #4 /home/anahita/src/components/com_people/dispatcher.php(55): ComBaseDispatcherDefault->_actionException(Object(AnCommandContext)) #5 /home/anahita/src/libraries/anahita/controller/abstract.php(142): ComPeopleDispatcher->_actionException(Object(AnCommandContext)) #6 /home/anahita/src/libraries/anahita/controller/abstract.php(242): AnControllerA in /home/anahita/src/libraries/default/base/controller/response/response.php on line 148

The only activity done by Admin is to update the SMTP setting.. nothing else.
I dont know why I always struggle with this :) :)

Exception Swift_TransportException with message "Expected response code 220 but got code "", with message """

var $mailer = 'smtp';
var $mailfrom = 'MyEmailId...';
var $fromname = 'Anahita Website';
var $sendmail = '/usr/sbin/sendmail';
var $smtpauth = '1';
var $smtpsecure = 'ssl';
var $smtpport = '465';
var $smtpuser = 'MyEmailId...';
var $smtppass = 'Mypassowrd.....';
var $smtphost = 'smtp.gmail.com';
Tried this configuration...with App password but no luck.

var $mailer = 'smtp';
var $mailfrom = 'mygmail';
var $fromname = 'Anahita Website';
var $sendmail = '/usr/sbin/sendmail';
var $smtpauth = '1';
var $smtpsecure = 'tls';
var $smtpport = '587';
var $smtpuser = 'mygmail';
var $smtppass = 'app password generated by google';
var $smtphost = 'smtp.gmail.com';
I Used SendInBlue and it worked like charm :)
Rastin Mehr liked this
I am seriously considering removing the mailer library and encourage people to use an external service such as Mailgun or SendInBlue. I'm glad to know that it worked like a charm.
Rajkumar Mundel liked this

Powered by Anahita