Topics

Tribe Support

Tribe Support's Topics

Maro  Ma

Maro Ma

3 weeks ago

No User Signup Page

@rastin Rastin: any update on the anahita.local/people/signup404 Not Foundissue?

  • 40 Comments
  • Last Comment by Maro Ma
I am wondering, did you pull code from the master branch in an existing project, or this is happening in a fresh installation?
Maro  Ma
Maro Ma
3 weeks ago Permalink
fresh installation
We are still working on the master branch so the code is unstable. For the time being, you can run the command:

$ php anahita site:configuration

and then look in the configuration.php file and see if there are any variables missing. For example, client_domain should be set to "anahita.local", and sef_rewrite = 1
So I just cloned Anahita from the master branch, and I installed it successfully. I noticed that for the database, I needed to use localhost instead of 127.0.0.1 because of how MySQL is set up on my machine; otherwise, it couldn't connect. I couldn't reproduce the 404 error that you are having.
Maro  Ma
Maro Ma
3 weeks ago Permalink
we are getting

Couldn't process file /var/www/anahita.local/vendor/anahita-platform/installation/sql/data.sql

Can u guide us on what we could be doing wrong?
What versions of php and MySQL are you using?
Maro  Ma
Maro Ma
3 weeks ago Permalink
Php 7.3.27 ,

mysql 8.0.23

ubuntu.20.04.1 for Linux on x86_64

Zend Engine v3.3.27
That seems like a file permissions issue. Can you check and see if the path /var/www/anahita.local/vendor/anahita-platform/installation/sql/data.sql exists and whether PHP has permissions to read it?

Also in configuration.php file make sure the variables are set to maximum error reporting:

var $debug = 1;
var $error_reporting = 30719;
I am testing with MySql 5.7. I'm wondering if Mysql 8.0 has issues with our current queries.
Maro  Ma
Maro Ma
2 weeks ago Permalink
@rastin Rastin: followed your instructions. Still No User Signup Page

we are get the following error:

“Couldn't process file /var/www/anahita.local/vendor/anahita-platform/installation/sql/data.sql
Maro  Ma
Maro Ma
2 weeks ago Permalink
this issue doesnt happen on stable package installation but happens when installing by pulling master branch using git clone.
Rastin Mehr liked this
Ok, let me do some more testing and get back to you
Can you please check and see if the database tables are created or not?
The only thing that has changed in that part of the code is that we are using localhost for the database host by default instead of 127.0.0.1
Another tip: drop the database before installing Anahita. It's possible that the database tables from the last attempt are still there.
Maro  Ma
Maro Ma
2 weeks ago Permalink
tried with mysql 5.7
but still got 404 error when i tried to use /people/signup


mysql> SHOW DATABASES;
+--------------------+
| Database |
+--------------------+
| information_schema |
| anahita |
| mysql |
| performance_schema |
| sys |
+--------------------+
5 rows in set (0.01 sec)
mysql> SHOW DATABASES anahita;
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'anahita' at line 1
mysql> USE anahita;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A
Database changed
mysql> SHOW TABLES;
+----------------------+
| Tables_in_anahita |
+----------------------+
| an_components |
| an_edges |
| an_migrator_versions |
| an_nodes |
| an_people_people |
| an_plugins |
| an_sessions |
+----------------------+
7 rows in set (0.00 sec)
mysql> SHOW FULL TABLES;
+----------------------+------------+
| Tables_in_anahita | Table_type |
+----------------------+------------+
| an_components | BASE TABLE |
| an_edges | BASE TABLE |
| an_migrator_versions | BASE TABLE |
| an_nodes | BASE TABLE |
| an_people_people | BASE TABLE |
| an_plugins | BASE TABLE |
| an_sessions | BASE TABLE |
+----------------------+------------+
7 rows in set (0.01 sec)





1:47
Maro  Ma
Maro Ma
2 weeks ago Permalink
1. we managed to install the anahita via pulling master branch using ssh.

2. can access the index.php and see the image above.

3. all the dbs and tables are created


but there is NOT such route people/signup
Rastin Mehr liked this
What's the value of $sef_rewrite in configuration.php file? It should be 1
Maro  Ma
Maro Ma
2 weeks ago Permalink
/* CORS Settings */
var $cors_enabled = 0;
var $cors_methods = 'POST, GET, DELETE, PUT, PATCH, OPTIONS';
var $cors_headers = 'Content-Type';
var $cors_credentials = 1;
/* Mailer Settings */
var $mailer = 'mail';
var $mailfrom = 'noreply@example.com';
var $fromname = 'Anahita Website';
var $sendmail = '/usr/sbin/sendmail';
/* SMTP Settings */
var $smtp_user = '';
var $smtp_pass = '';
var $smtp_host = 'localhost';
var $smtp_secure = 'ssl';
var $smtp_port = 25;
None of these variables are related to the issue you are having. Did you say that you can see the home page? If you see index.php in the generated URLs, that means sef_rewrite is 0, it should be one.

Are you using Nginx or Apache?
Unknown Person liked this

Powered by Anahita