Topics

Tribe Support

Tribe Support's Topics

Maro  Ma

Maro Ma

3 weeks ago

No User Signup Page

@rastin Rastin: any update on the anahita.local/people/signup404 Not Foundissue?

  • 40 Comments
  • Last Comment by Maro Ma
Maro  Ma
Maro Ma
2 weeks ago Permalink
@rastin sef_rewrite is 1

we are using Nginx
Maro  Ma
Maro Ma
2 weeks ago Permalink
@rastin sef_rewrite is 1

we are using Nginx
Maro  Ma
Maro Ma
2 weeks ago Permalink
@rastin
server {
listen 80;
server_name anahita.local www.anahita.local;
root /var/www/anahita.local/www/;

index index.html index.htm index.php;

location / {
try_files $uri $uri/ =404;
}

location ~ .php$ {
include snippets/fastcgi-php.conf;
fastcgi_pass unix:/var/run/php/php7.3-fpm.sock;
}

location ~ /.ht {
deny all;
}

}
Maro  Ma
Maro Ma
2 weeks ago Permalink
@rastin
This is the /etc/nginx/sites-available/anahita.local
4:17
I installed anahita in /var/www/
4:17
so the path is /var/www/anahita.local/
4:18
and the configuration.php is in /var/www/anahita.local/www/configuration.php
4:18
and by doing so, i am able to access the /var/www/anahita.local/www/index.php
4:18
on the browser localhost:80/index.php
You need this in your Nginx config file: try_files $uri $uri/ /index.php?$args; instead of what you have. At this point, it seems like your issue has to do with Nginx configuration and not Anahita.
Maro  Ma
Maro Ma
2 weeks ago Permalink
which version mysql do you recommend? ?
Maro  Ma
Maro Ma
2 weeks ago Permalink
server {
listen 80;
server_name anahita.local www.anahita.local;
root /var/www/anahita.local/www/;

index index.html index.htm index.php;

location / {
try_files $uri $uri/index.php?$args;
}

location ~ .php$ {
include snippets/fastcgi-php.conf;
fastcgi_pass unix:/var/run/php/php7.3-fpm.sock;
}

location ~ /.ht {
deny all;
}

}
I have done
Maro  Ma
Maro Ma
2 weeks ago Permalink
done. still getting same 404 error

(using mysql 5.7)
Is this the Nginx 404 page or Anahita 404 page that you are getting? If it is the Nginx 404 page, then the problem is in the Nginx configuration, not Anahita.
Maro  Ma
Maro Ma
2 weeks ago Permalink
its “Nginx 404”

are there any instructions regarding specific “Nginx configuration for Anahita”?
Maro  Ma
Maro Ma
2 weeks ago Permalink
does this still apply? 👇

Loading ...
#file-nginx-config
Yes, the only specific line is the try_files that I gave you. Otherwise, read the Nginx docs and examples and then craft something that works for your server.
Maro  Ma
Maro Ma
2 weeks ago Permalink
Local Installation finally succeeded with

Anahita specific nginx configuration
then install Stable package (Birth Release) with mysql 5.7

localost/people/signup
We finally get the Signup Page

However user creation "Create Administrator Account" function is not working

After fillingup fields with Name Email Password and clicking

We get a blank page

What are we missing?
Rastin Mehr liked this
It’s probably because Anahita tried to send you a confirmation email, but the server isn’t configured to do so. You can edit the configuration.php file and add the values for your mail server of choice. You can for example use an SMTP service such as Mailgun.
Unknown Person liked this
Maro  Ma
Maro Ma
2 weeks ago Permalink
@rastin Rastin: Administrator appears "created" in the database with logins etc but there is no Administrator page localhost/administrator

or

localhost/anahita/administrator
Yes, the first user becomes Super Admin and Anahita sends out an email with a confirmation link. This is for better security.

There is no "localhost.anahita/administrator" path in Anahita. All users log in using "localhost.anahita/people/session" path.
Unknown Person liked this
Maro  Ma
Maro Ma
2 weeks ago Permalink
since that Super Admin has already been created, how do we make Anahita still sendout this email “after the fact”?

Do we have to press a certain button?
Or delete Super Admin and Start over with Mailgun enabled?
You can either go to the database and enable the user or just drop the database and redo the initiation process after adding the Mailgun credentials to the configuration.php file.

1. add Mailgun credentials to the configuration.php file
2. drop database
3. php anahita site:init
By the way, we're going to improve this in future releases. We know that it is not as simple when your development environment is still new.
Maro  Ma
Maro Ma
2 weeks ago Permalink
This worked Thank You

Powered by Anahita